[flashrom] I have problem making latest flashrom

Adrian Glaubitz adrian.glaubitz at googlemail.com
Sat Dec 5 15:38:33 CET 2009


On Sat, Dec 5, 2009 at 3:22 PM, guy lacroix <glx at skynet.be> wrote:
> Dear Sirs,
> i learned how to install libpcidev,(zlib1g-dev), libftdi-dev. That is
> done.  I did not install subversion.
> Source code folder flashrom-0.9.1 is in /home/guy and there I type make
> flashrom.  Then I get output as in included error make flashrom.
> When I type sudo make flasrom I get
> guy at asus-p4b:~/flashrom-0.9.1$ sudo make flashrom
> [sudo] password for guy:
> Checking for a C compiler... found.
> Checking for FTDI support... found.
> cc -Os -Wall -Werror  -D'SERPROG_SUPPORT=1' -D'FT2232_SPI_SUPPORT=1'
> -D'FLASHROM_VERSION="0.9.1-r710"' -o physmap.o -c physmap.c
> cc1: warnings being treated as errors
> physmap.c: In function ‘rdmsr’:
> physmap.c:146: error: dereferencing type-punned pointer will break
> strict-aliasing rules
> make: *** [physmap.o] Fout 1
> guy at asus-p4b:~/flashrom-0.9.1$

I think the problem is this message:

cc1: warnings being treated as errors

The compilers treats normal warnings as errors and will therefore
stop. Usually a warning shouldn't be a problem though.
I can reproduce the error on Fedora 12, didn't test on Debian yet.
However, when using the latest code from svn, everything compiles

So please checkout the latest code from svn:

svn co svn://coreboot.org/flashrom/trunk flashrom

Install subversion prior to that.


More information about the flashrom mailing list