[flashrom] [PATCH] Add Winbond W25Qxx

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Wed Apr 21 09:10:29 CEST 2010

On 20.04.2010 21:41, David Hendricks wrote:
> On Tue, Apr 20, 2010 at 12:38 PM, Rudolf Marek <r.marek at assembler.cz> wrote:
>> Hash: SHA1
>> Hmm I just tried on VT8237S and I got
>> Found chip "Winbond W25Q80" (1024 KB, SPI) at physical address 0xfff00000.
>> ===
>> This flash part has status UNTESTED for operations: PROBE READ ERASE WRITE
>> Please email a report to flashrom at flashrom.org if any of the above
>> operations
>> work correctly for you with this flash part. Please include the flashrom
>> output with the additional -V option for all operations you tested (-V,
>> -rV,
>> - -wV, -EV), and mention which mainboard or programmer you tested.
>> Thanks for your help!
>> ===
>> Writing flash chip... Erasing flash before programming... Erasing flash
>> chip...
>> spi_block_erase_20 failed during command execution at address 0x0
>> spi_block_erase_52 failed during command execution at address 0x0
>> done.
>> Programming page:
>> Verifying flash... VERIFIED.
>> So either I did some mistake or something else is wrong ;)
> I'm pretty sure it's a chipset thing. Thanks for the patch!

Yes, this is a chipset driver problem. I will try to address this during
GSoC if I get accepted. Basically, VIA and Intel chipsets have a fixed
SPI command set right now, and the list of chipset-allowed SPI commands
has to be reprogrammed on the fly to support all known chip commands.



More information about the flashrom mailing list