[flashrom] help - flash chip unknown state - attached output files

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Sat Apr 24 23:21:48 CEST 2010


On 24.04.2010 22:26, csh tmp wrote:
> Thank you very much for the helpful, prompt response. Your time and efforts
> put into this are much appreciated. Looks like I need further help.
> After this issue early today morning, I went to sleep and when I woke
> up, found that
> the computer had powered off probably due to a transient power outage. When
> turned on again, it has booted up seemingly fine (so noticeable issues
> so far, 7 hours
> uptime after power-on).


> As Michael has suggested for verification, I now tried
> $  sudo flashrom -v current_bios_amibios3.19.img
> flashrom v0.9.1-r706
> No coreboot table found.
> Found chipset "Intel ICH5/ICH5R", enabling flash write... OK.
> This chipset supports the following protocols: Non-SPI.
> Calibrating delay loop... OK.
> Found chip "Winbond W39V040FA" (512 KB, FWH) at physical address 0xfff80000.
> Flash image seems to be a legacy BIOS. Disabling checks.
> Verifying flash... VERIFY FAILED at 0x0006e010! Expected=0x08,
> Read=0x27, failed byte count from 0x00000000-0x0007ffff: 0x6
> Now it says VERIFY FAILED. Please could you advise what to do now ?

No reason to worry. It seems your BIOS rewrites a small part of the ROM
on every boot. This is probably the date/time when the computer was
powered on, and you can ignore this failure. Basically, for most recent
BIOS, verify will work before reboot, and will fail after reboot because
the BIOS changed some flash contents.



More information about the flashrom mailing list