[flashrom] [PATCH] Fix NetBSD linking

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Fri Jun 4 03:51:16 CEST 2010

NetBSD needs libpciutils (which is called libpci on pretty much every
other platform and lives in the pciutils package) and apparently the
libpciutils on NetBSD needs the NetBSD-native libpci (no equivalent on
other platforms).

Thanks to Jonathan A. Kollasch for reporting.

Signed-off-by: Carl-Daniel Hailfinger <c-d.hailfinger.devel.2006 at gmx.net>

Index: flashrom-netbsd/Makefile
--- flashrom-netbsd/Makefile	(Revision 1028)
+++ flashrom-netbsd/Makefile	(Arbeitskopie)
@@ -220,8 +220,10 @@
 PROGRAMMER_OBJS += pcidev.o physmap.o hwaccess.o
 ifeq ($(OS_ARCH), NetBSD)
-LIBS += -lpciutils #		The libpci we want.
-LIBS += -l$(shell uname -p) #	For (i386|x86_64)_iopl(2).
+# The libpci we want is called libpciutils on NetBSD and needs NetBSD libpci.
+LIBS += -lpciutils -lpci
+# For (i386|x86_64)_iopl(2).
+LIBS += -l$(shell uname -p)
 ifeq ($(OS_ARCH), DOS)
 # FIXME There needs to be a better way to do this


More information about the flashrom mailing list