Difference between revisions of "Downloads"

From flashrom
Jump to navigation Jump to search
Line 32: Line 32:
** '''Installation of binaries:''' mine -i flashrom-0.9.0.tar.bz2
** '''Installation of binaries:''' mine -i flashrom-0.9.0.tar.bz2
* '''FreeBSD''': cd /usr/ports/sysutils/flashrom && make install clean
* '''FreeBSD''': cd /usr/ports/sysutils/flashrom && make install clean
:The version from trunk (latest revision while writing this is r888) is usable too but you '''NEED''' to install '''devel/libpci''', sysutils/dmidecode and devel/gmake from ports.
:The version from trunk (latest revision while writing this is r889) is usable too but you '''NEED''' to install '''devel/libpci''', sysutils/dmidecode and devel/gmake from ports.
:After installing, edit flashrom's Makefile and change line 253 (diff style):
:After installing, edit flashrom's Makefile and change line 253 (diff style):
:-      @$(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) .test1.c -o .test1 -lpci $(LIBS) >/dev/null 2>&1 &&    \
:-      @$(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) .test1.c -o .test1 -lpci $(LIBS) >/dev/null 2>&1 &&    \

Revision as of 18:24, 2 February 2010

You can browse the flashrom source code online, or download and install flashrom as explained below.

Requirements:

  • pciutils development package (pciutils-dev/libpci-dev/pciutils-devel, depending on OS/distribution)
  • zlib development package (zlib1g-dev/zlib-devel, depending on OS/distribution)
  • libftdi development package (libftdi-dev), optional support for the external FT2232SPI flasher.
  • subversion (if you checkout the source and build manually)

Manual installation from source:

If you just want to use the latest release, download flashrom 0.9.1 (source) here (sig).

If you want the latest source code (for developers), check out our code from subversion:

$ svn co svn://coreboot.org/flashrom/trunk flashrom
$ cd flashrom
$ make
$ sudo make install

Binary packages:

  • Debian: sudo aptitude install flashrom
  • Ubuntu: sudo aptitude install flashrom
  • Fedora: sudo yum install flashrom
  • Gentoo: emerge flashrom
  • Mandriva: urpmi flashrom
  • openSUSE: yast -i coreboot-utils
  • T2 SDE
    • Installation from source: Emerge-Pkg flashrom
    • Installation of binaries: mine -i flashrom-0.9.0.tar.bz2
  • FreeBSD: cd /usr/ports/sysutils/flashrom && make install clean
The version from trunk (latest revision while writing this is r889) is usable too but you NEED to install devel/libpci, sysutils/dmidecode and devel/gmake from ports.
After installing, edit flashrom's Makefile and change line 253 (diff style):
- @$(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) .test1.c -o .test1 -lpci $(LIBS) >/dev/null 2>&1 && \
into this:
+ @$(CC) -c $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) .test1.c -o .test1 -lpci $(LIBS) >/dev/null 2>&1 && \


Releases:


Windows port: In 2009, several patches for Windows, based on a more recent revision of flashrom, were made available:

  • [flashrom] GSoCs Winflashrom versus r126. [1]
  • [flashrom] [PATCH] Clean up before Windows support merge [2]
  • [flashrom] [PATCH] new windows port [3]